Lag, random crashes and invisible walls

  • the loading screen is seizure / nausea inducing

  • to say it is laggy is an understatement

  • random crashes

  • complete walls with art on them become “invisible” and sometimes randomly appear again

+1: exponential cost of space expansion is a massive time gate, I literally have nothing to do for days to stockpile money for a 4 cube expansion.

Hi!!

  1. We have heard this complaint before and are working on a fix.
  2. It typically depends on the gallery size, may we ask what your specs are?
  3. Optimization is an ongoing process. Are you doing something specific during the crash because that might be a bug we’re able to fix?
  4. This is a bug and we’re already working on fixing it?
  5. We’re also working in tweaks for the economy.

We appreciate the feedback! If you have more we’re always willing to hear them!

  • We have heard this complaint before and are working on a fix.
    Yay!

  • It typically depends on the gallery size, may we ask what your specs are?
    My trusty potato. Since 2012, she’s been good to me. (CPU AMD FX-6100 / 4 GB RAM / Gigabyte 970A-DS3P motherboard / AMD Radeon HD 7700 graphics card)

  • Optimization is an ongoing process. Are you doing something specific during the crash because that might be a bug we’re able to fix?
    Usually it happens when I’m trying to place something. Especially with larger assets.

  • This is a bug and we’re already working on fixing it?
    Yay!

  • We’re also working in tweaks for the economy.
    Yay for money!

About your “trusty potato”
It’s actually below minimum spec. We “require” 6gb of ram and a 7870.

Some galleries are big enough that they can require more ram than you actually have.

So this might contribute to your lag. And while we’re always optimizing we can’t guarantee that it will get much better unfortunately :frowning: But that won’t stop us from actively trying!

And about the crash, this is an issue we’re aware of. So whenever you place an item the game does a lot of collision tests on the asset being placed to see if the item can be placed. This is taking a lot of processing power. We are looking into possible fixes!